×
Home Support About us Extras

System Requirements

SoapMaker requires the full Windows operating system with support for legacy apps. (Note: Windows-RT and Windows S-mode do not support legacy apps like SoapMaker.)

You can run SoapMaker on a Windows tablet if it meets this requirement. You may want to consider adding a mouse and keyboard.

iPad and Android tablets, and Chromebook computers are not compatible with SoapMaker. But you can access SoapMaker on your PC from your tablet using software such as realVNC.

Mac users can run Windows on their mac using a solution such as:

IMPORTANT: Make sure you are running in the Windows environment before downloading SoapMaker, or it may not install correctly.

Many Mac users have purchased a cheap Windows computer just to run SoapMaker.